红联Linux门户
红联Linux论坛
Linux帮助

ubuntu17.10安装lnmp安装包的核心问题-gcc版本、g++版本

发布时间:2017-12-12 09:34:08来源:linux网站作者:黑熊一只
大致碰到的问题都是这样,不是php安装失败,就是MySQL安装失败,或者Nginx也安装失败
ubuntu17.10安装lnmp安装包的核心问题-gcc版本、g++版本
基本上是花式报错。后来找到了这个帖子:
ubuntu17.10安装lnmp安装包的核心问题-gcc版本、g++版本
 
简单来说就是gcc版本的问题
我想了想——切换版本:
先看看我们系统用的gcc和g++是什么版本 
gcc -v
可以获得的信息如下 
gcc version 7.2.0
如果我们想使用gcc5怎么办?首先看看有没有安装gcc5, 
ls /usr/bin/gcc*
结果只有/usr/bin/gcc  /usr/bin/gcc-7两个,那么我们需要安装 
sudo apt-get install gcc-5 gcc-5-multilib g++-5 g++-5-multilib
安装好后输入以下指令: 
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-5 40 
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-7 50
接着输入: 
sudo update-alternatives --config gcc
会看到如下的选项,有 3 个候选项可用于替换 gcc (提供 /usr/bin/gcc)。 
选择 路径 优先级 状态
------------------------------------------------------------
* 0 /usr/bin/gcc-5 50 自动模式
1 /usr/bin/gcc-5 50 手动模式
2 /usr/bin/gcc-7 40 手动模式
要维持当前值[*]请按回车键,或者键入选择的编号: 
要想用哪个gcc就输入编号吧。 
同样也要设置一下g++的 
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-5 50 
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.9 40
如果想删除可选项的话可以键入以下指令:
sudo update-alternatives --remove gcc /usr/bin/gcc-5
下面是查看g++版本可切换的
sudo update-alternatives --config g++
必须一句:gcc和g++的版本在同时切换到相同版本,比如:gcc7、g++7,切换到gcc5、g++5,才能编译成功。
大致如此。
ubuntu17.10安装lnmp安装包的核心问题-gcc版本、g++版本
安装完成,在浏览器输入:http://localhost/即可正常访问了。
 
本文永久更新地址:http://www.linuxdiyf.com/linux/33005.html
推荐教程
热点推荐