学Linux - 上红联!
Linux系统教程_红联Linux门户
Linux帮助

不管哪个ubuntu版本和ros版本都会出现段错误 pluginlib

时间:2017-09-14来源:linux网站 作者:路飞洗头用飘柔
不论ubuntu版本和ros版本应该都会出现。我的是ubuntu16.04+kinetic。
在使用pluginlib时,会报段错误。
 
因为自己编译了boost库并且sudo make install,和ros自带的boost产生冲突。
因为在安装ros时会自动安装boost,很多ros的可执行底层驱动也是依赖他自己装的boost的,如果我们自己编译boost并安装,是有可能和ros自带的冲突。
 
解决办法就是移除掉 /usr/local/include的boost头文件和/usr/local/lib里的boost库文件。
之后:
catkin_make clean
catkin_make
 
本文永久更新地址:http://www.linuxdiyf.com/linux/32596.html
------分隔线------