红联Linux门户
Linux帮助

Solaris 10下双机时间同步

发布时间:2008-01-14 00:01:12来源:红联作者:document
  软件环境:Solaris 10+Sun cluster3.1u4+SVM+Oracle 10g AS
  硬件环境:2*V440+1*SE3320
 
  下面这个是在安装Sun cluster之前完成的!系统上线以后最好采用NTP,冒然同步可能对数据产生影响!仅供学习参考!
  双机相互信任关系建立完成后,需要对双机进行时钟同步校正,以保证双机时钟同步。具体步骤如下:
查看当前主机时钟。在校正前,必须保证作为校正标准的主机系统时钟和实际时间一致。相关命令如下(在主机DB1上执行):
  # date
  修改主机时钟。如果主机时间和实际时间不一致,必须以root用户登录,修改主机时间,相关命令如下(在主机DB1上执行):
  # date mmddHHMMCCYY
  注意:
  (1) date命令格式说明:mm(月)dd(日)HH(小时/24时制)MM(分钟)CC(世纪减一,如21世纪则为20)YY(年),即CCYY为四位表示的年份;以上数字均为两位数,不足两位前面补零。如“date 122014302001”表示将时间调整为2001年12月20日14时30分。
  (2) 此命令平时尽量不用,系统时间变化可能带来不可预料的问题。
  同步双机时钟。
  solaris 10下双机时间同步需要先在两台主机上执行下面命令:
# svcs -a |grep time
disabled 13:31:24 svc:/network/daytime:dgram
disabled 13:31:24 svc:/network/daytime:stream
disabled 13:31:24 svc:/network/time:dgram
disabled 13:31:24 svc:/network/time:stream
# svcadm enable time:stream
# svcadm enable time:dgram
# svcs -a |grep time
disabled 13:31:24 svc:/network/daytime:dgram
disabled 13:31:24 svc:/network/daytime:stream
online 13:55:40 svc:/network/time:stream
online 13:55:45 svc:/network/time:dgram
  如果不做上面操作,会报错:
# rdate DB1
rdate: connect: Connection refused
  当修改主机系统时间和实际时间一致后,就可以用主机时钟来同步备机时钟,相关命令如下(在备机DB2上执行):
# rdate DB1
  如果是现网双机要同步时间的话,可以参考下面思路,可适用的系统环境:solaris 6~10
  1. 成为群集中任一节点上的超级用户。
  2. 在任一节点关闭群集并将其转到OBP 提示符下。
# scshutdown -g0 -y
  3. 将各个节点都引导成非群集节点。
ok boot -x
  4. 在node1节点上,通过运行date 命令来设置时间。
# date HHMMSS
  5. 在其他机器上,通过运行rdate 命令来使它们的时间与前面的那个节点的时间同步。
# rdate node1
  6. 引导每个节点以重新启动该群集。
# reboot
  7. 检验是否所有的群集节点均已做相应的更改。
在每个节点上,运行date 命令。
# date
文章评论

共有 0 条评论