红联Linux门户
Linux帮助

MariaDB ColumnStore 1.1.2 GA

发布时间:2017-11-22 09:57:30来源:红联作者:baihuo
MariaDB ColumnStore是在MariaDB 10.1基础上移植了 InfiniDB 4.6.2 构建的大规模并行,高性能,压缩,分布式开源列式存储引擎,类似收费产品Infobright。它设计用于大数据离线分析,用来抗衡Hadoop。你可以使用标准SQL语句进行查询,支持目前流行的sqlyog/navicat客户端工具连接,对业务方使用没有任何的不便,并且你不需要创建任何索引,不需要修改业务方的复杂SQL(自身就支持复杂的关联查询、聚合、存储过程和用户定义的函数),你唯一要做的就是把数据导入到ColumnStore里,就没你事了。这对一家没有Hadoop工程师的公司来说,MariaDB ColumnStore会是一个更好的替代产品。

Notable changes

Beta release of the Streaming Data Adapters: Out of box adapters for data integration between various data sources for specific use cases

MaxScale CDC Data Adapter is integration of the MaxScale CDC streams into MariaDB ColumnStore

Kafka Data Adapter is integration of the Kafka streams into MariaDB ColumnStore.

Bugs and issues fixed

self join cte queries from tpcds alternately fail with parsing error and succeed but with incorrect results

System in DBRM_READ_ONLY mode after Non-parent PM recovery under DataRedundancy

The addmodule command reported an invalid password error if cluster on the new module is not running

postConfigure on a DataRed setup should exiting when system install prompt is answered 'n'

MySQL replication is not replicating after installation

LDI and INSERT...SELECT causes mysqld to crash with long VARCHAR entries

MCS Replication setup failure - mysqld failed to restart

Debian 9 package: postConfigure failed to create /etc/rc.d/rc.local file

Replication setup failed when using ssh key and schema sync enabled

information_schema.columnstore_extents data_size calculation incorrect

On ovh data center servers, postConfigure crashed on upgrade

Dictionary deduplication cache is not working correctly

postConfigure reported system catalog creation error but database continue to work

此外还包含了很多其他 bug 修复。

软件详情:http://git.oschina.net/mirrors/mariadb

来自:开源中国社区
文章评论

共有 0 条评论