MongoDB是一个介于关系数据库和非关系数据库之间的产品, 是非关系数据库当中功能最丰富,最像关系数据库的。他支持的数据结构非常松散,是类似json的bjson格式,因此可以存储比较复杂的数据类型。Mongo最大的特点是他支持的查询语言非常强大,其语法有点类似于面向对象的查询语言,几乎可以实现类似关系数据库单表查询的绝大部分功能,而且还支持对数据建立索引。
它的特点是高性能、易部署、易使用,存储数据非常方便。主要功能特性有:
面向集合存储,易存储对象类型的数据。
模式自由。
支持动态查询。
支持完全索引,包含内部对象。
支持查询。
支持复制和故障恢复。
使用高效的二进制数据存储,包括大型对象(如视频等)。
自动处理碎片,以支持云计算层次的扩展性
支持RUBY,PYTHON,JAVA,C++,PHP等多种语言。
文件存储格式为BSON(一种JSON的扩展)
可通过网络访问
所谓“面向集合”(Collenction-Orented),意思是数据被分组存储在数据集中,被称为一个集合(Collenction)。每个 集合在数据库中都有一个唯一的标识名,并且可以包含无限数目的文档。集合的概念类似关系型数据库(RDBMS)里的表(table),不同的是它不需要定 义任何模式(schema)。
模式自由(schema-free),意味着对于存储在mongodb数据库中的文件,我们不需要知道它的任何结构定义。如果需要的话,你完全可以把不同结构的文件存储在同一个数据库里。
存储在集合中的文档,被存储为键-值对的形式。键用于唯一标识一个文档,为字符串类型,而值则可以是各中复杂的文件类型。我们称这种存储形式为BSON(Binary Serialized dOcument Format)。
MongoDB服务端可运行在Linux、Windows或OS X平台,支持32位和64位应用,默认端口为27017。推荐运行在64位平台,因为MongoDB
在32位模式运行时支持的最大文件尺寸为2GB。
MongoDB把数据存储在文件中(默认路径为:/data/db),为提高效率使用内存映射文件进行管理。
2012-08-08发布2.0.67正式版。上一个版本是2011-06-05的2.0.6.这个版本经过1个RC.包括如下改进
Configure Release Notes
Bug
[SERVER-2833] - mongod.exe does not shut down correctly as a Windows service
[SERVER-2942] - MapViewOfFileEx failed during large import
[SERVER-3097] - mongod --install uses wrong image path depending on current working directory
[SERVER-3969] - Shell interactive password prompt can't handle spaces
[SERVER-4291] - Assertion: 13273:single data buffer expected while using mongodump
[SERVER-4800] - mongos cursor handling with timeouts
[SERVER-4907] - sparse indexes break replication of array based operators
[SERVER-5473] - mongostat throws an error when connecting via a 1.8.x mongos - "unrecognized command: getnonce"
[SERVER-5594] - missed check of node index when initializing replica set with host down
[SERVER-5663] - Private pages accumulate in Windows RAM and page file when journaling
[SERVER-5680] - repl13.js failing on Windows 64-bit
[SERVER-5872] - autosplit would be triggered before data size touch chunksize. The return message "updatedExisting" of update is missed
[SERVER-5920] - bad reload of database config
[SERVER-5988] - where3.js leaving collections on slave at end of test in 2.0 branch
[SERVER-6006] - moveChunk fails with migration already in progress
[SERVER-6047] - $pullAll causes empty embedded object field to be created
[SERVER-6132] - a failure inside MakeChunkWritable should call abort/fassert instead of assert
[SERVER-6162] - backport of targeted shard ranges instead of broadcast on all queries
[SERVER-6167] - very verbose messaging with large numbers of collections
[SERVER-6178] - Cannot use mongos if subset of config servers can't read from or write to disk
[SERVER-6252] - Debug assertion in Windows debug build, bad code in any build, due to incorrect lock usage
[SERVER-6305] - option to turn off splitVectors on particular mongoses
[SERVER-6311] - FlushViewOfFile failures can result in invalid journal on Windows
[SERVER-6359] - mongoexport now outputs full strings in CSV mode
[SERVER-6372] - fassert identifier causes Windows 64bit 2008+ to fail compile in 2.0 branch
[SERVER-6391] - Yielding with one (or more) active writer and heavy read load results in severe performance degradation
[SERVER-6509] - ignore SIGPIPE
[SERVER-6512] - ReplicaSetMonitor::_checkConnection does not check upper bounds for the indexes
Improvement
[SERVER-4992] - Disable dropDatabase command on "config" if sharded collections exist with data
[SERVER-6414] - use regular file io, not mmap for external sort
下载:32位 http://fastdl.mongodb.org/linux/mongodb-linux-i686-2.0.7.tgz
64位 http://fastdl.mongodb.org/linux/mongodb-linux-x86_64-2.0.7.tgz
源码 http://downloads.mongodb.org/src/mongodb-src-r2.0.7.tar.gz
来自:开源中国社区

