红联linux Linux通用技术 - Linux发行版技术 - 企业应用 - 实验室  Linux论坛

您的位置: 红联linux >> Linux通用技术 >>

Linux技术与应用

>> 查看内容 -学Linux必读Linux学习教程推荐下载发新话题 (游客可发贴)

编译squid4

jszj1983发布于 2016-12-31 | 次阅读   字号:     (网友评论 0 条) 我要评论


In file included from old_api.cc:12:
../../src/base/PackableStream.h:30: 错误:expected ‘;’ before ‘override’
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/functional:56,
from ../../src/sbuf/forward.h:12,
from ../../src/sbuf/SBuf.h:18,
from ../../src/format/Format.h:14,
from ../../src/HttpHeaderTools.h:13,
from ../../src/SquidConfig.h:18,
from old_api.cc:24:
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/typeinfo:36: 错误:expected ‘;’ before end of line
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/typeinfo:36: 错误:expected ‘}’ before end of line
In file included from old_api.cc:12:
../../src/base/PackableStream.h: In constructor ‘PackableStreamBuf::PackableStreamBuf(Packable&)’:
../../src/base/PackableStream.h:23: 错误:类‘PackableStreamBuf’没有名为‘buf_’的字段
../../src/base/PackableStream.h:23: 错误:‘buf_’在此作用域中尚未声明
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/functional:56,
from ../../src/sbuf/forward.h:12,
from ../../src/sbuf/SBuf.h:18,
from ../../src/format/Format.h:14,
from ../../src/HttpHeaderTools.h:13,
from ../../src/SquidConfig.h:18,
from old_api.cc:24:
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/typeinfo: At global scope:
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/typeinfo:36: 错误:expected unqualified-id before end of line
/usr/lib/gcc/x86_64-redhat-linux/4.4.7/../../../../include/c++/4.4.7/typeinfo:36: 错误:expected declaration before end of line
cc1plus: warnings being treated as errors
cc1plus: 错误:无法识别的命令行选项“-Wno-deprecated-register”
make[3]: *** [old_api.lo] 错误 1
make[3]: Leaving directory `/root/squid-4.0.17/src/mem'
make[2]: *** [all-recursive] 错误 1
make[2]: Leaving directory `/root/squid-4.0.17/src'
make[1]: *** [all] 错误 2
make[1]: Leaving directory `/root/squid-4.0.17/src'


编译安装出现上面错误,不懂请各位帮忙看一下

 我要评论
发表评论,与各位同人交流。回复请点击下方的我要评论按钮(游客可回复),要发表贴子请点击 发新话题 (游客可发贴)
 关注热点

Linux教程下载?
Linux学习教程推荐下载”(请点击),Linux教程免费下载。

求助Linux问题?
论坛有39版块,覆盖所有Linux技术层面。前往“红联Linux论坛

 

Linux系统教程 | Linux入门 | Linux管理 | Linux技巧 | Linux命令 | Ubuntu系统 | Linux服务器 | Linux数据库 | Linux开发

合作 | 关于我们 | 联系我们 | 导航 | 会员注册

©2017 红联 Powered by SupSite