红联Linux门户
红联Linux论坛
Linux帮助

ubuntu16.04编译QT5.6所依赖的库

发布时间:2018-01-03 11:43:53来源:linux网站作者:隔壁王叔叔a
首先在QT的根目录下,阅读README文件!
里面介绍了ubuntu环境下,编译该版本的QT需要安装的包。
New dependencies in Qt 5
------------------------
Linux: On systems running X11, the XCB libraries are required for the platform plugin to build. qtbase/src/plugins/platforms/xcb/README
lists the required packages.
Qt 5 can make use of the ICU libraries providing Unicode and Globalization support (see http://site.icu-project.org/). They are required for building QtWebKit.
On Linux, they will be auto-detected.
On Windows, they need to be manually installed and the "include" and "lib" folders of the ICU installation must be appended to the INCLUDE and LIB environment variables after calling the Windows SDK setup script.
The "bin" folder of the ICU installation should be appended to the PATH environment variable in order to for the DLLs to be found at run-time.
 
我们能够发现,在 . qtbase/src/plugins/platforms/xcb/README 的文件里,有我们所需要的安装包!
 
下面的这些安装包,是经过我修改的,适用于ubuntu16.04的安装包:
sudo apt-get install libxcb1 libxcb1-dev libx11-xcb1 libx11-xcb-dev libxcb-keysyms1 libxcb-keysyms1-dev libxcb-image0 libxcb-image0-dev libxcb-shm0 libxcb-shm0-dev libxcb-icccm* libxcb-icccm4-dev libxcb-sync* libxcb-sync-dev libxcb-render-util0 libxcb-render-util0-dev libxcb-xfixes0-dev libxrender-dev libxcb-shape0-dev libxcb-randr0-dev libxcb-glx0-dev libxcb-xinerama0-dev
推荐教程
热点推荐